If you've recently purchased a WinterNode Server, your service should already be available to use Java 17, through our Java Version Selector.


Java Version Recommendation


Java Version Selector

On June 4, 2021, we introduced our self-managed Java Version Selector that allows you to change the Java Version used on your server.

<aside> 💡 If you are not seeing the prompt shown below, please see Version Selector Not Showing

</aside>

Upon initial startup, you are prompted to select a Version. If you do not select a version, our system will automatic select the recommended version. To change versions, please see the following section titled Change Java Version.

awYLfrYZW6SLWTx.png

Type the number you wish to use into the terminal field, then the server will continue startup.

hth4KrP7uJzTDkc.gif

Change Java Version

If you need to switch to a different Java Version, simply go to ManagementFile Managementand delete the file disable_prompt_for_java_version. On next startup, you'll be able to make your new selection.

https://s3-us-west-2.amazonaws.com/secure.notion-static.com/b07853ee-5604-467c-99a0-58573763ebd0/WvND6as5jhPuuUL.gif

Java Version Selector Not Showing

If you are seeing the box shown below within the first few lines of the server startup, as opposed to the second box, you will need to contact our support team.

openjdk version "11.0.10" 2021-01-19
OpenJDK Runtime Environment 18.9 (build 11.0.10+9)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.10+9, mixed mode, sharing)

<aside> 💡 If you are not seeing the box below, please contact our Support Team. As the Java Version Selector is not available on your server.

</aside>